ForumCała strona

Nawigacja

Aktualnie online

Gości online: 7

Użytkowników online: 0

Łącznie użytkowników: 25,350
Najnowszy użytkownik: viacamp

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

MajsterBieda
28.02.2021 00:54:28
No wesołe wesołe! Grin Grin

hoopak
24.02.2021 19:43:03
Wesołe jest życie staruszka Grin

piterus
14.02.2021 22:31:41
@JazOOn Wcale nie był prostszy... Po prostu byliśmy bardziej plastyczni... Teraz reumatyzm przeszkadza... Pfft

JazOOn
14.02.2021 21:11:09
Kiedyś internet był prostszy...

piterus
28.01.2021 17:17:39
Trzeba... Niech zwierzaki przez chwile mają trochę wytchnienia... Pfft

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Zobacz temat

Polski Oficjalny Support PHP-Fusion » PHP-Fusion v5.00-v6.01 Support » Błędy i korekty
 Drukuj temat
Polskie znaki w Extended Profile
weasel
Mam taki problem. Zainstalowałem "MOD-Extended_Profile_2.12[6.01.13]-1.1" na PHP-Fusion v6.01.15 zastępując pliki tak jak było napisane w instrukcji. Wszystko działa ok tylko w dodatkowych polach nie ma polskich znaków tylko krzaczki. Co odpowiada za kodowanie i jak to naprawic? Albo może jakieś inne rozwiązanie aby mieć dodatkowe pola dla usera?


PW od moderatora:
  1. Przeniesienie tematu - Pieka 09.09 - 09:21
 
piotrek199214
Zamień plik polish.php na ten w załączniku.
Dwa napisy były źle.
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Plik w folderze locale>polish.php odpowiada za napisy- tak na przyszłość ;).
piotrek199214 dodał/a następującą plik:
polish_1_2_3.rar [840Bajtów / 430 Pobrane]

Edytowane przez piotrek199214 dnia 13.05.2008 15:38:15
 
www.piocom.eu
weasel
Dzięki Wink
To rozwiązało jeden problem akurat ten mniej istotny (Interfejs wtyczki).
Głównym problemem jest to że nazwy pól i ich wartości nie mają polskich znaków Sad
Te domyślne pola mogą mieć polskie znaki a te dodane już się krzaczą. W bazie danych jedne i drugie wyświetlaja się krzaczasto mimo że te domyslne na stronie są ok.
Myślę że coś jest nie tak na drodze wtyczka -> baza. Podczas zapisywania w bazie coś jest źle z kodowaniem. Niestety nie mam dużego doświadczenia w PHP więc nie-bardzo wiem gdzie tego szukać.
Edytowane przez szymon dnia 13.05.2008 16:58:55
 
piotrek199214
Masz lecz spr wszystkie funkcje, ponieważ robiłem na szybkiego. Podmień wszystkie pliki które masz w załączniku.

//poprawiłem.
piotrek199214 dodał/a następującą plik:
extended_profile_admin.rar [6.21kB / 455 Pobrane]

Edytowane przez piotrek199214 dnia 13.05.2008 17:50:01
Pomogłem Ci? Wystarczy podziękować i oznaczyć post jako pomocny pomogl[1]_1.png
Tanie tworzenie wtyczek, masz problem napisz.
 
www.piocom.eu
weasel
100x Dzięki
Super wszystko działa Smile
Polacy nie gęsi Grin
 
kamek
Okej. Problem krzaczków rozwiązany, ale ja mam jeszcze jeden problem z tą twoją paczką.

Otóż nie wiedziec czemu w Edycji profilu na końcu każdej nazwy nowego pola dodaje mi się "3"

Czyli wszędzie mam np "kierunek studiów", a w oknie edycji profilu mam "kierunek studiów3". Jak to zmienić, bo kompletnie nie mam pojęcia gdzie tego mam szukać?
 
ICEK
Odświeżam, bo widzę, że problem nadal jest, ja właśnie też mam te cyferki i za nić nie mogę ich zlikwidować. Szukałem w kodzie, szukałem w bazie i nic, nigdzie nie ma tej nieszczęsnej "3". Czy mógłby ktoś looknąć na ten bajer?

Pozdrawiam Smile
Edytowane przez ICEK dnia 10.04.2009 22:04:16
 
www.modlinski.net
micko3
I jak Panowie temat? Tez nie mogę sobie poradzić z tymi '3'.
Pozdrawiam

Wiadomość doklejona:
Ok. Wydaje się, że znalazłem rozwiązanie. W pliku edit_profile.php należy w linii:
Pobierz kod źródłowy  Rozwiń Kod źródłowy PHP

usunąć:
Pobierz kod źródłowy  Rozwiń Kod źródłowy PHP

U mnie działa.
Pozdrawiam
Edytowane przez Pieka dnia 07.06.2009 11:36:53
 
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl