ForumCała strona

Nawigacja

Aktualnie online

Gości online: 7

Użytkowników online: 0

Łącznie użytkowników: 25,349
Najnowszy użytkownik: BlackRosse

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

piterus
14.04.2021 20:57:50
Nie ma duchów! Nie ma żadnych duchów! Nikt nie robi: Uuuuuu... Nikt nie świeci, w kącie, nikt nie stoi, Nikt nie straszy tuuuu...

khaman
14.04.2021 18:32:53
Duchy jakieś Shock

Pieka
14.04.2021 17:39:10
Smile

krystian1988
04.04.2021 00:00:00
Dobrego jajka Smile

krystian1988
31.03.2021 10:34:14
Witam wszystkich Grin po Covidzie Smile Widzę że wszyscy cali Grin

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Zobacz temat

 Drukuj temat
Brak dodanego wpisu w shoutboxie na stronie głównej
BenLomax
Witam.

Mam nadzieję, że dobrze sprecyzowałem temat, a więc: korzystałem przez pewien czas z Shoutboxa od Bartka - wszystko działało ok, do czasu... - ale w związku z problemem odświeżania pod FF (dziwne bo pod IE działa) chciałem powrócić do poprzedniego standardowego Shoutboxa.

Poprzez PA zmieniłem panel no i ... właśnie nic.

Na stronie głównej dodawanie wiadomości do Shoutboxa nie działa, ale o dziwo kiedy przejdę np do archiwum Shoutboxa i wtedy w panelu Shoutboxa wpiszę wiadomość ta się wyświetla. W sumie Shoutbox działa, jeśli panel wyświetlany jest na każdej podstronie prócz strony głównej.

Na stronie głównej w newsach wstawione mam mapy z googla. Możliwe, że się "gryzą"?? Jakiś czas temu standardowy Shoutbox działał bez problemu.

Może jakiś pomysł co zrobić ewentualnie podpowiedź jak namierzyć ów błąd.
Strona to http://www.grupar...owastop.pl

edycja:

Gdy chcę dodać wpis ze strony głównej po wciśnięciu przycisku wyślij, nic się nie dzieję (nawet nie jest dodany wpis do bazy danych).
Wyłączyłem wszystkie panele - nic.
Odkomendowałem wyświetlanie newsów na stronie głównej - by wykluczyć konflikt z mapami google - też nie działa.
Edytowane przez Pieka dnia 01.04.2011 20:20:39
21293.png
 
Pieka
Jesli jestes pewny, ze tabela wraz z wszystkimi polami w bazie jest ok, pliki na 100% oryginalne i dla Twojej wersji skryptu, a wszystko rozbija sie tylko o strone glowna, to pozostaje Ci na poczatek wylaczyc wszystkie panele i sprawdzic po uprzednim odswiezeniu strony, czy nawet wyczyszczeniu pamieci przegladarki.
Nie zaszkodzi rowniez dodac testowego usera i podac nam jego dane.
Jestem jaki jestem Smile
 
www.php-fusion.pl
BenLomax
Co do tabel to nie jestem pewien na 100%, wiem jedno,że nie było w nich nic grzebane. Jak dodaje wysyłam wpis z podstrony to dodaje go do BD.

Pliki są z oryginalnej paczki.

Wyłączyłem wszystkie panele. Wyczyściłem pamięć przeglądarki i nic.

Dodałem usera:
l: kontotestowe
h: 123456
21293.png
 
Pieka
Masz powazniejszy problem niz Ci sie wydaje, bo nie dziala dodawanie BBCode na calej stronie. Cos wiecej mieszales niz podajesz i zapewne nie tylko z shoutboksem. Nadpisz pliki odpowiedzialne za BBCode oraz plik includes/jscript.js.
Jestem jaki jestem Smile
 
www.php-fusion.pl
BenLomax
Pieka napisał/a:
Cos wiecej mieszales niz podajesz i zapewne nie tylko z shoutboksem.

W ostatnim czasie nic nie było zmieniane w kodzie.
Nie wykluczam, że to jakaś zmiana z przed paru tygodni, heh ale jaka?!

Pieka napisał/a:
Nadpisz pliki odpowiedzialne za BBCode oraz plik includes/jscript.js.

Nadpisałem includes/bbcodes/

oraz plik includes/jscript.js

i nadal to samo.

Wiadomość doklejona:
Hmm dziwne, jest to, że wiadomość można edytować. Czyli wynika na to, że problem tkwi w samym wysłania wiadomości ze strony głównej.

Wiadomość doklejona:
BenLomax napisał/a:
Pieka napisał/a:
Cos wiecej mieszales niz podajesz i zapewne nie tylko z shoutboksem.

W ostatnim czasie nic nie było zmieniane w kodzie.
Nie wykluczam, że to jakaś zmiana z przed paru tygodni, heh ale jaka?!

Pieka napisał/a:
Nadpisz pliki odpowiedzialne za BBCode oraz plik includes/jscript.js.

Nadpisałem includes/bbcodes/

oraz plik includes/jscript.js

i nadal to samo.

Wiadomość doklejona:
Hmm dziwne, jest to, że wiadomość można edytować. Czyli wynika na to, że problem tkwi w samym wysłaniu wiadomości ze strony głównej.

Edytowane przez BenLomax dnia 10.10.2009 02:15:26
21293.png
 
Pieka
BBCode z tego co widze juz dziala, o czym slowem nie wspomniales. Jeden problem mniej.
Masz cos poczarowane z wyswietlaniem strony glownej/ukrywaniem w adresie index.php. Byc moze to wlasnie jest przyczyna problemow. To rowniez warto sprawdzic, bo shoutbox sam z siebie nie przestaje wysylac wiadomosci.
Jestem jaki jestem Smile
 
www.php-fusion.pl
BenLomax
Pieka napisał/a:
BBCode z tego co widze juz dziala, o czym slowem nie wspomniales. Jeden problem mniej.

Nie wiedziałem,że nie działa.
Pieka napisał/a:
Masz cos poczarowane z wyswietlaniem strony glownej/ukrywaniem w adresie index.php. Byc moze to wlasnie jest przyczyna problemow. To rowniez warto sprawdzic, bo shoutbox sam z siebie nie przestaje wysylac wiadomosci.

Kurczaki, faktycznie. 'Ktoś' (jedynie mógł to zrobić hosting) dopisał mi w pliku .htaccess dwie linijki kodu. Po ich usunięciu wydaje się, że wszystko działa.

Wielkie dzięki Pieka z pomoc. Dzięki Tobie zaoszczędziłem sporo czasu (sam bym na to raczej nie wpadł) oraz nerwów.
Jeszcze raz dzięki za ekspresowa i fachową pomoc.
Pozdrawiam.
21293.png
 
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl