ForumCała strona

Nawigacja

Aktualnie online

Gości online: 8

Użytkowników online: 0

Łącznie użytkowników: 25,362
Najnowszy użytkownik: IgorKopr

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

JazOOn
13.05.2022 16:33:41
Raany boskie jestem kioskiem... MajsterBieda wrócił

MajsterBieda
25.04.2022 00:06:35
Matko Kozłoska to TO jeszcze istnieje???? Shock Angry Cool Pfft

krystian1988
24.02.2022 22:56:13
@khaman, pracuję w CZ to rozumiem Grin jak Przemek mam blisko do granicy Grin

krystian1988
24.02.2022 22:55:35
Chápu. Vždy můžete něco změnit, aby to bylo lepší.

khaman
24.02.2022 15:43:40
To se nevrati pane Havranek. Jak to Czesi mówią. Lata przestoju w rozwoju zrobiły swoje.

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Zobacz temat

 Drukuj temat
PHP Fusion 7 pod PHP8
adi
Witam nie dawno dostałem info od dostawcy, że od kwietnia zmieniają na PHP8 i jak chcę mieć PHP7 to będę musiał dopłacić, to tylko 20% więcej, ale jednak.
Moje pytanie brzmi, czy będzie dużo roboty by php-fusion 7 działał na PHP8.
Pozdrawiam.


PW od moderatora:
  1. Przeniesienie tematu - khaman 07.03.2022 12:43

Tylko dwie rzeczy są nieskończone: wszechświat oraz ludzka głupota, choć nie jestem pewien co do tej pierwszej.

Albert Einstein

Nie posiadam GG FB czy tam jeszcze czegoś innego jak co PW
 
Apis
cartoons napisał(a):

... z tego co się orientuję, to php-fusion 7 działa do wersji 5.6, nie działa na PHP 7.


Nieprawda - PHP Fusion v7.02.07 działa pod PHP 7.x - wystarczy zastosować to: http://www.php-fu...ost_184824
Instrukcja przejścia z wersją PHPFusion v7.02.07 na PHP 7.x tu: http://www.php-fu...ost_185358

Można też sprawdzić, czy aby przypadkiem nie pójdzie na PHP 8.x - co jest całkiem możliwe....
Edytowane przez Apis dnia 02.03.2022 21:27:38
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
adi
Witam właśnie dokładnie o te modyfikację, przepraszam że nie sprecyzowałem. Co do próby pod PHP8 nie zadziałało, tyle że nie wiem czy sam czysty czy może jakaś wtyka.
Pozdro all.
Tylko dwie rzeczy są nieskończone: wszechświat oraz ludzka głupota, choć nie jestem pewien co do tej pierwszej.

Albert Einstein

Nie posiadam GG FB czy tam jeszcze czegoś innego jak co PW
 
Apis
W sumie PHPFusion v.7.xx czy 8.xx to jest niemal bez różnicy: działa w wersji 8 wszystko z v.7 (za wyjątkiem być może paru bardzo starych wtyczek). Upgrade jest bezproblemowy a ta wyższa wersja PHPFusion działa na PHP 8.x. Jedyny problem jaki miałem z PHPFusion v.8 to nie działające forum, ale to mógł być tylko mój problem (specyfika serwera lub jego ustawienia) - krystian1988 testowo instalował PHPFusion v.8 i forum u niego działało.
Edytowane przez Apis dnia 07.03.2022 12:19:52
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
adi
Witam jak na serwerze zmienię na PHP8 to mam tylko tło tak jakby nie czytało bazy danych, zrobię pod folder, wgram czysty z 2 bazą i zobaczę, dam znać jaki efekt.
Pozdro.
Tylko dwie rzeczy są nieskończone: wszechświat oraz ludzka głupota, choć nie jestem pewien co do tej pierwszej.

Albert Einstein

Nie posiadam GG FB czy tam jeszcze czegoś innego jak co PW
 
Apis
PHPFusion v.8 działa na PHP 8 od wersji 8.00.80 (na 100%). Pobierz tu: https://www.php-f...ile_id=617
Wcześniejsze nie wiem na pewno ale miałem 8.00.60 i działała na PHP 8. Obecna wersja to 8.00.100 - https://www.php-f...ile_id=621
Edytowane przez Apis dnia 08.03.2022 08:32:19
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
adi
Witam zmieniłem najpierw na PHP7.4 bo dostałem info od admina serwera że ta wersja będzie utrzymana przez rok bez dopłaty.
Tyle że mi w PA pokazuje taki błąd
Pobierz kod źródłowy  Rozwiń Kod źródłowy


a oto ta linia kodu
Pobierz kod źródłowy  Rozwiń Kod źródłowy

dodam jeszcze że to tylko w panelu admina i mogę dać by ten błąd pominąć, ale z czystej ciekawości czym to może być spowodowane ?
Pozdrawiam i z góry dzięki za sugestie.
Tylko dwie rzeczy są nieskończone: wszechświat oraz ludzka głupota, choć nie jestem pewien co do tej pierwszej.

Albert Einstein

Nie posiadam GG FB czy tam jeszcze czegoś innego jak co PW
 
Apis
W zacytowanym fragmencie kodu zmień w liniach 243 i 244' panel_filename' na 'panel'

To wina użytej skórki. Miałem podobny problem w skórce 'PublisherBlogger' i pomogło, ale nie daję gwarancji, że w tej pomoże. Czy w innych skórkach też jest ten błąd?
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
krystian1988
Myślę że PHP-Fusion v7.02.07 pójdzie na PHP8. Aktualnie jestem po małych aktualizacjach skryptu nad działaniem na PHP8 i działa. Zresztą jeśli ktoś jest ciekawy to zapraszam do testowania na https://www.kryst...l/news.php
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
adi
Witam to dobrze działało do czasu a teras znowu jakiś przestało , wszędzie gdzie jest fisions jest tylko tło, co może być przyczyną?

Pozdrawiam


PW od moderatora:
  1. Ogólna uwaga - khaman 03.05.2022 21:38

Edytowane przez adi dnia 03.05.2022 16:09:01
Tylko dwie rzeczy są nieskończone: wszechświat oraz ludzka głupota, choć nie jestem pewien co do tej pierwszej.

Albert Einstein

Nie posiadam GG FB czy tam jeszcze czegoś innego jak co PW
 
krystian1988
Wersja z PHP7 nie będzie działała na PHP8.
Jest tam sporo zmian + zmiana w driver. Forum w administracji, szukajka, bbcode itd. Ja mam na swojej stronie już dostosowaną wersję i aktualnie ją testuję. Jeśli nie znajdę więcej błędów to udostępnię wersję pod PHP8.
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl